You are here

Add new comment

Yes it's on the MD8800.
I tried "modprobe saa7134 i2c_scan=1 card=12 tuner=33 oss=1"
But no success. Anyone succeded with the analog part ? and the DVB part ?

dmesg dump

[ 1057.577660] saa7130/34: v4l2 driver version 0.2.14 loaded
[ 1057.578319] ACPI: PCI Interrupt 0000:02:01.0[A] -> GSI 17 (level, low) -> IRQ 217
[ 1057.578538] saa7133[0]: found at 0000:02:01.0, rev: 209, irq: 217, latency: 32, mmio: 0xfdeff000
[ 1057.578736] saa7133[0]: subsystem: 16be:0007, board: Medion 7134 [card=12,insmod option]
[ 1057.578936] saa7133[0]: board init: gpio is 0
[ 1057.708482] tuner 0-004b: chip found @ 0x96 (saa7133[0])
[ 1057.716472] tuner 0-004b: microtune: companycode=8000 part=22 rev=06
[ 1057.716688] tuner 0-004b: microtune unknown found, not (yet?) supported, sorry :-/
[ 1057.742443] saa7133[0]: i2c eeprom 00: be 16 07 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
[ 1057.742843] saa7133[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
[ 1057.743230] saa7133[0]: i2c eeprom 20: 01 40 01 02 02 03 01 00 06 ff 00 23 02 51 96 2b
[ 1057.743619] saa7133[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
[ 1057.744013] saa7133[0]: i2c eeprom 40: ff 28 00 c0 96 10 03 00 c0 1c fd 79 44 9f c2 8f
[ 1057.744431] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1057.744849] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1057.745237] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1057.749435] saa7133[0]: i2c scan: found device @ 0x10 [???]
[ 1057.752432] saa7133[0]: i2c scan: found device @ 0x1c [???]
[ 1057.765418] saa7133[0]: i2c scan: found device @ 0x96 [???]
[ 1057.768415] saa7133[0]: i2c scan: found device @ 0xa0 [eeprom]
[ 1057.771412] saa7133[0]: i2c scan: found device @ 0xa2 [???]
[ 1057.788396] saa7133[0] Cant determine tuner type 28 from EEPROM
[ 1057.788574] saa7133[0] Tuner type is 33
[ 1057.788705] tuner 0-004b: Tuner has no way to set tv freq
[ 1057.788849] tuner 0-004b: Tuner has no way to set tv freq
[ 1057.788987] saa7133[0]: dsp access error
[ 1057.789103] saa7133[0]: dsp access error
[ 1057.789220] saa7133[0]: dsp access error
[ 1057.789336] saa7133[0]: dsp access error
[ 1057.789529] saa7133[0]: dsp access error
[ 1057.789660] saa7133[0]: dsp access error
[ 1057.789777] saa7133[0]: dsp access error
[ 1057.789894] saa7133[0]: dsp access error
[ 1057.790010] saa7133[0]: dsp access error
[ 1057.790126] saa7133[0]: dsp access error
[ 1057.803521] saa7133[0]: registered device video0 [v4l2]
[ 1057.803653] saa7133[0]: registered device vbi0
[ 1057.803744] saa7133[0]: registered device radio0
[ 1057.803818] saa7133[0]: dsp access error
[ 1057.803880] saa7133[0]: dsp access error
[ 1057.803961] ACPI: PCI Interrupt 0000:02:04.0[A] -> GSI 20 (level, low) -> IRQ 225
[ 1057.804094] saa7133[1]: found at 0000:02:04.0, rev: 209, irq: 225, latency: 32, mmio: 0xfdefc000
[ 1057.804220] saa7133[1]: subsystem: 16be:0008, board: UNKNOWN/GENERIC [card=0,autodetected]
[ 1057.804362] saa7133[1]: board init: gpio is 0
[ 1057.933321] tuner 1-004b: chip found @ 0x96 (saa7133[1])
[ 1057.959309] saa7133[1]: i2c eeprom 00: be 16 08 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
[ 1057.959755] saa7133[1]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
[ 1057.960116] saa7133[1]: i2c eeprom 20: 01 40 01 02 02 03 01 0f 0f ff 00 3c 02 51 96 2b
[ 1057.960482] saa7133[1]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
[ 1057.960840] saa7133[1]: i2c eeprom 40: ff 28 00 c0 96 10 03 01 c0 1c fd 79 44 9f c2 8f
[ 1057.961198] saa7133[1]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1057.961558] saa7133[1]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1057.961916] saa7133[1]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1057.966336] saa7133[1]: i2c scan: found device @ 0x10 [???]
[ 1057.970311] saa7133[1]: i2c scan: found device @ 0x1c [???]
[ 1057.983306] saa7133[1]: i2c scan: found device @ 0x96 [???]
[ 1057.986310] saa7133[1]: i2c scan: found device @ 0xa0 [eeprom]
[ 1057.989315] saa7133[1]: i2c scan: found device @ 0xa2 [???]
[ 1057.997018] tuner 1-004b: tuner type not set
[ 1057.997136] tuner 1-004b: tuner type not set
[ 1057.997757] saa7133[1]: registered device video1 [v4l2]
[ 1057.998252] saa7133[1]: registered device vbi1

I tried only card=12 (tuner autodetect => tuner=63)

dmesg dump

[ 1126.361540] saa7130/34: v4l2 driver version 0.2.14 loaded
[ 1126.362175] ACPI: PCI Interrupt 0000:02:01.0[A] -> GSI 17 (level, low) -> IRQ 217
[ 1126.362408] saa7133[0]: found at 0000:02:01.0, rev: 209, irq: 217, latency: 32, mmio: 0xfdeff000
[ 1126.362601] saa7133[0]: subsystem: 16be:0007, board: Medion 7134 [card=12,insmod option]
[ 1126.362791] saa7133[0]: board init: gpio is 0
[ 1126.482744] tuner 0-004b: chip found @ 0x96 (saa7133[0])
[ 1126.489740] tuner 0-004b: type set to 63 (Philips FMD1216ME MK3 Hybrid Tuner)
[ 1126.514709] saa7133[0]: i2c eeprom 00: be 16 07 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
[ 1126.515102] saa7133[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
[ 1126.515500] saa7133[0]: i2c eeprom 20: 01 40 01 02 02 03 01 00 06 ff 00 23 02 51 96 2b
[ 1126.515891] saa7133[0]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
[ 1126.516287] saa7133[0]: i2c eeprom 40: ff 28 00 c0 96 10 03 00 c0 1c fd 79 44 9f c2 8f
[ 1126.516676] saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1126.517114] saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1126.517510] saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1126.526696] saa7133[0] Cant determine tuner type 28 from EEPROM
[ 1126.526838] saa7133[0] Tuner type is 63
[ 1126.532691] saa7133[0]: dsp access error
[ 1126.532808] saa7133[0]: dsp access error
[ 1126.532925] saa7133[0]: dsp access error
[ 1126.533040] saa7133[0]: dsp access error
[ 1126.533232] saa7133[0]: dsp access error
[ 1126.533354] saa7133[0]: dsp access error
[ 1126.533472] saa7133[0]: dsp access error
[ 1126.533588] saa7133[0]: dsp access error
[ 1126.533709] saa7133[0]: dsp access error
[ 1126.533826] saa7133[0]: dsp access error
[ 1126.547566] saa7133[0]: registered device video0 [v4l2]
[ 1126.547691] saa7133[0]: registered device vbi0
[ 1126.547782] saa7133[0]: registered device radio0
[ 1126.547860] saa7133[0]: dsp access error
[ 1126.547926] saa7133[0]: dsp access error
[ 1126.548015] ACPI: PCI Interrupt 0000:02:04.0[A] -> GSI 20 (level, low) -> IRQ 225
[ 1126.548164] saa7133[1]: found at 0000:02:04.0, rev: 209, irq: 225, latency: 32, mmio: 0xfdefc000
[ 1126.548299] saa7133[1]: subsystem: 16be:0008, board: UNKNOWN/GENERIC [card=0,autodetected]
[ 1126.548454] saa7133[1]: board init: gpio is 0
[ 1126.677900] tuner 1-004b: chip found @ 0x96 (saa7133[1])
[ 1126.703872] saa7133[1]: i2c eeprom 00: be 16 08 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
[ 1126.704381] saa7133[1]: i2c eeprom 10: 00 ff 86 0f ff 20 ff 00 01 50 32 79 01 3c ca 50
[ 1126.704772] saa7133[1]: i2c eeprom 20: 01 40 01 02 02 03 01 0f 0f ff 00 3c 02 51 96 2b
[ 1126.705162] saa7133[1]: i2c eeprom 30: a7 58 7a 1f 03 8e 84 5e da 7a 04 b3 05 87 b2 3c
[ 1126.705548] saa7133[1]: i2c eeprom 40: ff 28 00 c0 96 10 03 01 c0 1c fd 79 44 9f c2 8f
[ 1126.705941] saa7133[1]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1126.706327] saa7133[1]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1126.706713] saa7133[1]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1126.707113] tuner 1-004b: tuner type not set
[ 1126.707240] tuner 1-004b: tuner type not set
[ 1126.707878] saa7133[1]: registered device video1 [v4l2]
[ 1126.708408] saa7133[1]: registered device vbi1

What make you think about card=12 (medion 7134) ?

Thank you for your help.